Hot-Honeys



.

Author Topic: Coppermine stopped working  (Read 333 times)

0 Members and 1 Guest are viewing this topic.

Offline ncilswdk2

  • Newbie
  • *
  • Joined: Jan 2017
  • Posts: 4
  • Reputation: 0
Coppermine stopped working
« on: January 02, 2017, 02:31 am »
Only the thumbnails will be downloaded not the full size images. Has anyone else had this problem or know a solution?

Offline firewaran

  • Moderator
  • *****
  • Joined: Apr 2016
  • Posts: 257
  • Reputation: 18
  • Gender: Male
Re: Coppermine stopped working
« Reply #1 on: January 03, 2017, 04:58 pm »

Offline ncilswdk2

  • Newbie
  • *
  • Joined: Jan 2017
  • Posts: 4
  • Reputation: 0
Re: Coppermine stopped working
« Reply #2 on: January 03, 2017, 09:35 pm »
I did not give an example because it appears to be a problem on all coppermine sites that I visit. As an example this one does not work: http://shaymitchelldaily.net/photos/thumbnails.php?album=537

Offline SenileDog

  • Moderator
  • *****
  • Joined: Apr 2016
  • Location: US West Coast
  • Posts: 584
  • Images: 653
  • Reputation: 25
  • Gender: Male
Re: Coppermine stopped working
« Reply #3 on: January 04, 2017, 01:11 am »
Try this, and let us know if all coppermine sites you know are working fine with this pattern.

Topic: http://hot-honeys.com/index.php?topic=5429.0

Label: coppermine2

Type: update

URL Pattern:

Code: [Select]
^https?:\/\/(?:www\.)?.+?\/(\w+\/)?displayimage\.php\?album=
Search Pattern:

Code: [Select]
function(pageData, pageUrl) {
var hUrl = pageUrl.match(/https?:\/\/(?:www\.)?.+?\/(?:\w+\/)?/);
var iUrl = pageData.match(/src="(albums\/[^\"]+)normal_([^\"]+)"/);
return iUrl ? {imgUrl: hUrl + iUrl[1] + iUrl[2], status: "OK"} : {imgUrl: null, status: "ABORT"}
}

Offline ncilswdk2

  • Newbie
  • *
  • Joined: Jan 2017
  • Posts: 4
  • Reputation: 0
Re: Coppermine stopped working
« Reply #4 on: January 04, 2017, 01:29 am »
That fixes it. Thanks!

Offline firewaran

  • Moderator
  • *****
  • Joined: Apr 2016
  • Posts: 257
  • Reputation: 18
  • Gender: Male
Re: Coppermine stopped working
« Reply #5 on: January 04, 2017, 08:02 pm »
The reason for an example is easy. We volunteer our time to solve the hosts if it is in our power to do so.
We do not volunteer to search the web for an example where you have already an example at hand.
So please always provide one, best is the link you just tried and you noticed it didn't work.
Saves us and you time and increases chances that you get a solution faster.

Offline artfulbodger

  • Moderator
  • *****
  • Joined: Apr 2016
  • Location: Northern Hemisphere
  • Posts: 146
  • Reputation: 14
Re: Coppermine stopped working
« Reply #6 on: January 04, 2017, 11:25 pm »
Thank you Fire, I'm liable to tag this thread as an example as to what to do.
Everyone - please learn from this - give the coders something to work with!

Offline SenileDog

  • Moderator
  • *****
  • Joined: Apr 2016
  • Location: US West Coast
  • Posts: 584
  • Images: 653
  • Reputation: 25
  • Gender: Male
Re: Coppermine stopped working
« Reply #7 on: January 05, 2017, 01:27 am »
And you guys are so nicer than I am,   :redface: I simply ignore bad requests. Happy New Year, BTW. SD

Offline firewaran

  • Moderator
  • *****
  • Joined: Apr 2016
  • Posts: 257
  • Reputation: 18
  • Gender: Male
Re: Coppermine stopped working
« Reply #8 on: January 05, 2017, 05:08 pm »
Maybe next time we "remove" such requests and pm them to redo it according our guideline :p

happy new year to you too  :happy:

Offline hdtor

  • Newbie
  • *
  • Joined: Jan 2017
  • Location: turkey
  • Posts: 2
  • Reputation: 0
  • Gender: Male
Re: Coppermine stopped working
« Reply #9 on: January 14, 2017, 12:07 am »
Try this, and let us know if all coppermine sites you know are working fine with this pattern.

Topic: http://hot-honeys.com/index.php?topic=5429.0

Label: coppermine2

Type: update

URL Pattern:

Code: [Select]
^https?:\/\/(?:www\.)?.+?\/(\w+\/)?displayimage\.php\?album=
Search Pattern:

Code: [Select]
function(pageData, pageUrl) {
var hUrl = pageUrl.match(/https?:\/\/(?:www\.)?.+?\/(?:\w+\/)?/);
var iUrl = pageData.match(/src="(albums\/[^\"]+)normal_([^\"]+)"/);
return iUrl ? {imgUrl: hUrl + iUrl[1] + iUrl[2], status: "OK"} : {imgUrl: null, status: "ABORT"}
}

Thank you for this however how i can make this script for works "fullsize=1" ? I cant download fullsize of pictures on this website: http://jenniferlawrence.us/photos/thumbnails.php?album=lastup&cat=134&page=1

i can only get normal size of pictures. If you help me i will be happy. thanks :)

Offline SenileDog

  • Moderator
  • *****
  • Joined: Apr 2016
  • Location: US West Coast
  • Posts: 584
  • Images: 653
  • Reputation: 25
  • Gender: Male
Re: Coppermine stopped working
« Reply #10 on: January 14, 2017, 01:50 am »
Try this:

Topic: http://hot-honeys.com/index.php?topic=5429.0

Label: coppermine2

Type: update

URL Pattern:

Code: [Select]
^https?:\/\/(?:www\.)?.+?\/(\w+\/)?displayimage\.php\?album=
Search Pattern:

Code: [Select]
function(pageData, pageUrl) {
var hUrl = pageUrl.match(/https?:\/\/(?:www\.)?.+?\/(?:\w+\/)?/);
var iUrl = pageData.match(/src="(albums\/[^\"]+)normal_([^\"]+)"/);
if (!iUrl) iUrl = pageData.match(/src="(albums\/[^\"]+)([^\"]+)"/);
return iUrl ? {imgUrl: hUrl + iUrl[1] + iUrl[2], status: "OK"} : {imgUrl: null, status: "ABORT"}
}


Offline marc

  • Newbie
  • *
  • Joined: Jan 2017
  • Posts: 1
  • Reputation: 0
Re: Coppermine stopped working
« Reply #11 on: January 17, 2017, 07:16 pm »
Thank you so much, this works perfectly!  :thumbsup:

Offline hdtor

  • Newbie
  • *
  • Joined: Jan 2017
  • Location: turkey
  • Posts: 2
  • Reputation: 0
  • Gender: Male
Re: Coppermine stopped working
« Reply #12 on: February 09, 2017, 12:33 am »
thank you also have another problem.

http://chloemoretz.org/photographs/thumbnails.php?album=lastup&cat=141

cant get images from this website. always getting:  "Restarting HTTP Request" and after "Request failed. Too many retries"

I guess gallery owner using some kind of protection againts image-host grabber ? Is there any solution for this ?

Thank you so much.

Offline SenileDog

  • Moderator
  • *****
  • Joined: Apr 2016
  • Location: US West Coast
  • Posts: 584
  • Images: 653
  • Reputation: 25
  • Gender: Male
Re: Coppermine stopped working
« Reply #13 on: February 09, 2017, 02:32 am »
Are you sure you have the code from reply #10 on this thread?

Official hostf.xml is NOT and ALMOST NEVER up to date, read this to understand the process:

http://hot-honeys.com/index.php?topic=3906.0

Official hostf.xml can be 2 or 3 months behind!

I get 60 pics from http://chloemoretz.org/photographs/thumbnails.php?album=lastup&cat=141

First pic I get with IHG is size 334,354 same as the one I get by saving the pic manually.

If you know of some bigger HD pic, give us the link to the first pic, I do not know how to get them.

Even Thread Sucker is working like a breeze, can download all pics (2183) from the 37 pages in one shot of IHG.

Cheers, SD